Installation on Windows with Cygwin

This guide will help you install TELEMAC-MASCARET on Windows Using only cigwin and pip.

The prerequisites for this installations are: - Having administrator access on your computer - Having internet access (or a PyPi mirror)

Installing cygwin

First download the Cygwin installer from here

Directly launching that installer will install cygwin. However because we have a list of prerequisites we want cygwin to install we will run the installation in command line instead.

First open a command terminal as administrator (You can find instruction on how to do it here).

Then run the following command:

setup-x86_64.exe -P _autorebase,alternatives,base-cygwin,base-files,bash,binutils,bzip2,ca-certificates,coreutils,crypt,crypto-policies,csih,cygrunsrv,cygutils,cygwin,cygwin-debuginfo,cygwin-devel,dash,diffutils,editrights,file,findutils,gawk,gcc-core,gcc-fortran,gcc-g++,getent,git,git-svn,grep,groff,gzip,hostname,info,ipc-utils,less,libapr1,libaprutil1,libargp,libatomic1,libattr1,libblkid1,libbrotlicommon1,libbrotlidec1,libbz2_1,libcbor,libcom_err2,libcrypt-devel,libcrypt0,libcrypt2,libcurl4,libdb5.3,libedit0,libexpat1,libfdisk1,libffi6,libfido2,libfreetype-devel,libfreetype6,libgcc1,libgdbm4,libgdbm6,libgdbm_compat4,libgfortran4,libgfortran5,libgmp10,libgomp1,libgssapi_krb5_2,libiconv,libiconv2,libidn2_0,libintl8,libiodbc2,libisl22,libk5crypto3,libkrb5_3,libkrb5support0,liblapack-devel,liblapack0,liblz4_1,liblzma5,libmetis-devel,libmetis0,libmpc3,libmpfr6,libmysqlclient18,libncursesw10,libnghttp2_14,libnsl2,libopenblas,libopenldap2_4_2,libopenmpi-devel,libopenmpi40,libopenmpifh40,libopenmpiusef08_40,libopenmpiusetkr40,libp11-kit0,libpcre1,libpipeline1,libpkgconf3,libpng-devel,libpng16,libpng16-devel,libpopt-common,libpopt0,libpq5,libproj15,libpsl5,libquadmath0,libreadline7,libsasl2_3,libserf1_0,libsigsegv2,libsmartcols1,libsodium-common,libsodium23,libsqlite3_0,libssh-common,libssh4,libssl1.0,libssl1.1,libstdc++6,libtasn1_6,libtirpc-common,libtirpc3,libunistring2,libuuid-devel,libuuid1,libzmq-devel,libzmq5,login,man-db,mariadb-common,metis,mingw64-x86_64-binutils,mingw64-x86_64-gcc-core,mingw64-x86_64-gcc-fortran,mingw64-x86_64-headers,mingw64-x86_64-runtime,mingw64-x86_64-windows-default-manifest,mingw64-x86_64-winpthreads,mintty,mysql-common,ncurses,openblas-debuginfo,openblas-doc,openmpi,openssh,openssl,p11-kit,p11-kit-trust,perl,perl-Error,perl-Scalar-List-Utils,perl-TermReadKey,perl-YAML,perl_autorebase,perl_base,pkg-config,pkgconf,proj,publicsuffix-list-dafsa,python-pip-wheel,python-setuptools-wheel,python3,python3-devel,python36,python36-devel,python36-setuptools,rebase,rsync,run,sed,subversion,subversion-perl,tar,terminfo,terminfo-extra,tzcode,tzdata,util-linux,vim-minimal,w32api-headers,w32api-runtime,which,windows-default-manifest,xz,zlib-devel,zlib0

Going froward in the the installation and also to run telemac we will be using the Cygwin terminal (mintty.exe). It should be on your desktop otherwise it should be in the cygwin directory (C:\cygwin64\bin\mintty.exe if you used default installation folder)

Within the cygwin terminal the “C:\” folder path is ”/cygdrive/c”.

Installing Python packages

Download the following file:

requirement.txt
attrs==19.3.0
backcall==0.1.0
bleach==3.1.5
cppy==1.1.0
cycler==0.10.0
Cython==0.29.19
decorator==4.4.2
defusedxml==0.6.0
entrypoints==0.3
importlib-metadata==1.6.0
ipykernel==5.3.0
ipython==7.15.0
ipython-genutils==0.2.0
ipywidgets==7.5.1
jedi==0.17.0
Jinja2==2.11.2
jsonschema==3.2.0
jupyter==1.0.0
jupyter-client==6.1.3
jupyter-console==6.1.0
jupyter-core==4.6.3
kiwisolver==1.2.0
MarkupSafe==1.1.1
matplotlib==3.2.1
mistune==0.8.4
mpi4py==3.0.3
nbconvert==5.6.1
nbformat==5.0.6
nose==1.3.7
notebook==6.0.3
numpy==1.18.4
packaging==20.4
pandocfilters==1.4.2
parso==0.7.0
pexpect==4.8.0
pickleshare==0.7.5
prometheus-client==0.8.0
prompt-toolkit==3.0.5
ptyprocess==0.6.0
Pygments==2.6.1
pyparsing==2.4.7
pyrsistent==0.16.0
python-dateutil==2.8.1
pyzmq==19.0.1
qtconsole==4.7.4
QtPy==1.9.0
scipy==1.3.1
Send2Trash==1.5.0
six==1.15.0
terminado==0.8.3
testpath==0.4.4
tornado==6.0.4
traitlets==4.3.3
wcwidth==0.2.3
webencodings==0.5.1
widgetsnbextension==3.5.1
zipp==3.1.0

Run the following command

python3 -m pip install -r requirement.txt

Getting Telemac sources

Follow the procedure described here

Compiling Telemac

In the explication below:

  • “root” refers to path to your TELEMAC_MASCARET

Copy “root”/configs/pysource.template.sh into “root”/configs/pysource.win.sh Edit the file and replace:

  • <path-to-install> by “root”
  • <your-config> by win

Source the file (if run from “root” otherwise change the path to the pysource file):

source configs/pysource.win.sh

Try running:

config.py

You should get something like that:

$ config.py


Loading Options and Configurations
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

  _                        _
 | |                      | |
 | |_  _ __  _   _  _ __  | | __
 | __|| '__|| | | || '_ \ | |/ /
 | |_ | |   | |_| || | | ||   <
  \__||_|    \__,_||_| |_||_|\_\



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

win:


    +> Windows 8 with gfortran and mpich (from automatic installer)

    +> root:    /cygdrive/c/opentelemac/trunk
    +> module: ad / api / artemis / bief
               damocles  / gaia  / gretel  / hermes
               identify_liq_bnd  / khione  / mascaret  / nestor
               parallel  / partel  / postel3d  / sisyphe
               special  / stbtel  / telemac2d  / telemac3d
               tomawac / waqtel


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~



My work is done

If this is ok run:

compile_telemac.py

Running Telemac

To check that everything is okay run a test case:

cd $HOMETEL/examples/telemac2d/gouttedo
telemac2d.py t2d_gouttedo.cas --ncsize=2 
installation_on_windows_with_cygwin.txt · Last modified: 2020/06/29 09:49 by y.audouin